Redis cluster between 2 servers, Waiting for the cluster to join takes forever

I want to make redis cluster, I have 2 server and each server have 3 redis (for 3 masters & 3 slaves).

Let’s say :

  • server 1 : IP (redis port : 7000, 7002, 7003)
  • server 2 : IP (redis port : 7001, 7004, 7005)

Firewall is not running.

I run cluster create on server 2

./redis-cli --cluster create --cluster-replicas 1

and after I type yes, this is happen

it takes forever waiting for the cluster to join

here is one of my redis.conf

protected-mode no
port 7001
tcp-backlog 511
timeout 0
tcp-keepalive 300
daemonize no
loglevel notice
logfile /home/redis2/redis-log.log
databases 16
always-show-logo no
set-proc-title yes
proc-title-template "{title} {listen-addr} {server-mode}"
stop-writes-on-bgsave-error yes
rdbcompression yes
rdbchecksum yes
dbfilename dump.rdb
rdb-del-sync-files no
dir ./
replica-serve-stale-data yes
replica-read-only yes
repl-diskless-sync no
repl-diskless-sync-delay 5
repl-diskless-load disabled
repl-disable-tcp-nodelay no
replica-priority 100
acllog-max-len 128
lazyfree-lazy-eviction no
lazyfree-lazy-expire no
lazyfree-lazy-server-del no
replica-lazy-flush no
lazyfree-lazy-user-del no
lazyfree-lazy-user-flush no
oom-score-adj no
oom-score-adj-values 0 200 800
disable-thp yes
appendonly yes
appendfilename "appendonly.aof"
appendfsync everysec
no-appendfsync-on-rewrite no
auto-aof-rewrite-percentage 100
auto-aof-rewrite-min-size 64mb
aof-load-truncated yes
aof-use-rdb-preamble yes
lua-time-limit 5000
cluster-enabled yes
cluster-node-timeout 5000
slowlog-log-slower-than 10000
slowlog-max-len 128
latency-monitor-threshold 0
notify-keyspace-events ""
hash-max-ziplist-entries 512
hash-max-ziplist-value 64
list-max-ziplist-size -2
list-compress-depth 0
set-max-intset-entries 512
zset-max-ziplist-entries 128
zset-max-ziplist-value 64
hll-sparse-max-bytes 3000
stream-node-max-bytes 4096
stream-node-max-entries 100
activerehashing yes
client-output-buffer-limit normal 0 0 0
client-output-buffer-limit replica 256mb 64mb 60
client-output-buffer-limit pubsub 32mb 8mb 60
hz 10
dynamic-hz yes
aof-rewrite-incremental-fsync yes
rdb-save-incremental-fsync yes
jemalloc-bg-thread yes

I don’t understand why this happen, can someone help me?

I think I knew the answer, I haven’t open the offset bus port 10000, so redis keep trying to join forever

Hello @robinrev ,

I also facing similar issue while trying to upgrade Redis version from 5.0.7 to 7.2.4. Initially when I opened the port the new node joined the cluster but for some unknown reason it failed, Hence I did a CLUSTER FORGET. After that when I try to add the same node again its taking forever, I even tried removing the config file to attain a new NodeID but that too is not helping.

Have anyone faced this issue?