Libgomp: Thread creation failed: Resource temporarily unavailable

I have a Redis Graph instance working on Kubernetes on top of an RHEL8 image.
Redis Server version is 6.2.6 and Redis Graph version is 2.2.13
We’ve created nearly 7.5 million nodes as a part of a test but as soon as we started loading relationships the server exits with the following error.
libgomp: Thread creation failed: Resource temporarily unavailable
There’s no memory or CPU pressure in terms of Kubernetes. The pod has 31Gi memory and 5000m CPU limit.
user limits are as follows.

core file size          (blocks, -c) unlimited
data seg size           (kbytes, -d) unlimited
scheduling priority             (-e) 0
file size               (blocks, -f) unlimited
pending signals                 (-i) 1030813
max locked memory       (kbytes, -l) 64
max memory size         (kbytes, -m) unlimited
open files                      (-n) 1048576
pipe size            (512 bytes, -p) 8
POSIX message queues     (bytes, -q) 819200
real-time priority              (-r) 0
stack size              (kbytes, -s) 8192
cpu time               (seconds, -t) unlimited
max user processes              (-u) 4194304
virtual memory          (kbytes, -v) unlimited
file locks                      (-x) unlimited

I failed to find which resource becomes temporarily unavailable during the creation of relationships. We ran a similar test on a Windows development machine without any issues.

Hi @serdarkalayci,
We’ve yet to encounter this issue, this is what I was able to quickly find online

Please let me know if changing system limits managed to solve this.
Thank you.

Hello @SWilly22, thanks for your reply. I saw the same thread and tried all the thing mentioned there to no avail.
Tried the same test on the official Redis Graph image and all worked successfully. I think there was something amiss with the base image we’ve been given.