MISCONF Redis is configured to save RDB snapshots problem on ec2

I`m using REDIS for data cache and I get error “MISCONF Redis is configured to save RDB snapshots, but is currently not able to persist on disk. Commands that may modify the data set are disabled.”

Why I get this error in every few hour ? I create place for data to be stored " CONFIG SET dir “/var/lib/redis” " but after few hour everything disappear… So I have to create folder again.

I`m using AWS EC2 ( ubuntu)

Is there anyone who can help me solve this problem

Two thoughts:

  1. There is a permissions issue - the directory permissions are getting altered somehow in the background
  2. Your Redis server is restarting and the default directory is something you don’t have permissions. Alter redis.conf instead of using CONFIG SET

@kyle I do it on conf file

and I restart my server too , but problem is still the same.Its only work when I do CONFIG SET…

@cedoburic OK. I’ve seen this before. Are you sure you’re starting your sever with the conf file?

@kyle Well when I installed REDIS I do redis-cli monitor , and after that I have it running (right ? ) I installed REDIS using this instruction https://drive.google.com/file/d/1Ri_vGkyqInvjnuTueXcTUL8gseFdGzzb/view

Last 2 day I spend fixing this error … But its always work few hours and then everything disappear

I’ve never seen that particular tutorial before, there are lots of things that can go wrong though. It’s definitely not canonical

Generally you have to start the redis server with first argument pointing to the file (see this quick start which is verified good). Double check everything is working as you specified in your conf file. In absence of a valid redis.conf file, redis will start will a defaults and it does this almost silently. It’s a pretty common mix up.

It seems more of permission/configuration issue rather than redis issue. How do you start the redis server ? Via command line ? or systemd/daemons?

In general, if you are using it only for cache and can tolerate for cache loss, you can disable the RDB snapshots altogether.