Unable to disable persistence

We are facing an issue with redis persisting data with the dump.rdb file, which is not desirable for us. Reviewing the many posts on this issue we have configured 'save “” ’ and ‘appendonly no’ n our redis.conf file. However, we still see the file created, although not consistently. We have found that connecting with redis-cli and issuing a ‘save “”’ seems to stop it going forward. We are confident that our redis.conf file is being loaded by redis because other settings are taking effect. Are we missing anything to disable persistence in all cases?

To verify that Redis has snapshots disabled call CONFIG GET save - the value should be the empty string.

Note, however, that Redis will create the RDB file if the SAVE or BGSAVE commands are invoked. Also, the default replication mode (non-diskless) creates a similar file automatically.