Timeout performing GET (5000ms)

Hi there.
I have huge issues with timeout to my redis client.
Error I get is

Timeout performing GET (5000ms), next: GET PROD_Portal_8BACFFEF-D600-43B9-B2FC-8795CCAD95C5, inst: 0, qu: 0, qs: 1, aw: False, rs: ReadAsync, ws: Idle, in: 131072, in-pipe: 8192, out-pipe: 0, serverEndpoint:, mc: 1/1/0, mgr: 7 of 10 available, clientName: OnlinebookingV3, IOCP: (Busy=4,Free=996,Min=8,Max=1000), WORKER: (Busy=242,Free=32525,Min=8,Max=32767), v:

I keep getting told that its an issue with my redis setup.
I have tried some things they haven’t worked for me so far.

The setup is going through a proxy (HaProxy) and then to a high-availability redis setup.
So i connect to my redis through the proxy on port 6399.
And the proxy knows 3 redis instance with 1 master. The failover in my setup works great but when i get “alot” of connections about (1000) the setup is stalling and i get timeout. I have changed the maxconn setting on the proxy to 20000 connections and i still get the issue (default was 488)

How can I troubleshoot further than this?
Maybe it’s just me but i can’t seem to find a setting in redis that i can change that might help me.

Do you have any long-running queries that might take over 5 seconds complete? I’d suggest checking the slowlog first:


Hi Kyle
When I go to the redis-cli and type SLOWLOG GET 10 I don’t see anything.
I know some packages might be a little big around 180KB.
But all the machines it is running on a Hyper-V with 40Gbps connection between the them.
When there is a lot of activity, I can see that it runs around 20MB/s on the server.