Build instructions for 1.8.1

Hi, we are using RS 1.8.1 in our production clusters and we are looking to find the build instructions for that version. Is there a way to get access to the instructions for v1 somehow? The current instructions produce an error:

/home/redis/RediSearch1.8.1$ sudo make setup
Makefile:76: /rules: No such file or directory
make: *** No rule to make target ‘/rules’. Stop.

We are already running RS2 for some of our services. It would be extremely helpful if you could share the old build instructions for v1 until we can migrate the rest.

Thank you!

1.8 build instruction should be the same as 1.6 build instructions: Quick Start - RediSearch Documentation

Can you try (from the git root directory, and assuming you have cmake installed):

> mkdir build
> cd build
> cmake ../
> make

Hi Meir, we tried that and it worked fine! Thank you, appreciate your help here.

We have many RS1 indexes running, and for some of our key patterns do not adhere to the foo:* leaf structure, hence the delay in adopting RS2.