Redis search build fails from source

Redissearch module build fails with make version being too old what version of make should we be using; not able find the version dependencies in the documentation;

[mgutha@hostname RediSearch]$ make build
deps/readies/mk/main:6: *** GNU Make version is too old. Aborting… Stop.

[mgutha@hostname RediSearch]$ make --version
GNU Make 3.82
Built for x86_64-redhat-linux-gnu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Operating System: CentOS Linux 7 (Core)
Kernel: Linux 3.10.0-1160.11.1.el7.x86_64
Architecture: x86-64

Can you please call ./sbin/setup? it should straight the environment dependencies.

@gkorland thanks for the info; tried building the module on docker ubuntu container on my local; our nodes don’t have connectivity to internet to download all the dependencies what ./sbin/setup is looking for i was able to build the module on docker and scp’d to redis server (centos07) we are running to

9508:S 15 Dec 2022 13:24:03.984 # Module /etc/redis/ failed to load: /etc/redis/ cannot open shared object file: No such file or directory
9508:S 15 Dec 2022 13:24:03.985 # Can't load module from /etc/redis/ server aborting
[root@redis ~]# ls -l /etc/redis/
-rwxr-xr-x 1 redis redis 5773768 Dec 15 13:22 /etc/redis/
[root@redis ~]#

Redissearch module was build on Ubuntu
Redis-server is running on Centos7

File does exist on the node with appropriate permissions tried changing ownership to redis:redis and 777 nothing works. Any insight on this would help.


Hello @muralikgutha,
In the build method you have tried, one has to match the container image of the build to the runtime OS. That is, if one intends to run on CentOS 7, the build should be performed on a CentOS 7 image and not on an Ubuntu one.
It is possible to diagnose possible problem with the .so using ldd /etc/redis/, looking for missing libraries, but the solution is to build it as suggested above.