Disable remember redis password

Hi all,

We are configuring AWS elasticache and now we are trying to add redisinsight to manage elasticache cluster, but we have a problem with the authentication:

  • We don’t want to save the password, because we want to use a token every log into redisinsight.

There’re some config file, change possibility, etc to don’t allow to save redis password?



AFAIK there is NO option as of now in RedisInsight to disabling saving database password.


  1. Deploy RedisInsight in EC2 with restricted access
  2. Add/Remove the Database connection everytime when you use RedisInsight
  3. Raise Feature Request /Feedback to Redis Labs team
  4. Its recommended installing HTTPS, whitelisting IP addresses that have access to RedisInsight and/or making it available within your VPN/internal network. Additionally, make sure you use a strong admin password for your database.

Hope this solves for time being.

Hi @gerardgorrion and thanks for reaching out with this question.

As @suyog mentioned, there is currently no option to disable saving the password for connecting to a database. We took a note of your request and added that to the backlog for future prioritization (that should not be long!).

As we are always interesting to hear how users are leveraging the tool, can I ask how you are envisioning to use RedisInsight in such configuration and who will be the users (developers, devops,…)? :slight_smile:

Hi @gerardgorrion, i assume you need to disable password since you need to setup some kind of an access control to a few users.

There is a workaround that I can think of:

  1. Setup many redis insight groups according to your access control needs, e.g. one instance per group
  2. Use a reverse proxy with authentication that would secure the installed redis insight