redisinsight graph view

RedisGraph Support-

This is probably not the correct place for this question, but I can’t seem to find any RedisInsight repo, group, help forum, etc… other than redislabs support email address, which was also hit with the following question.

I’ve been evaluating RedisGraph as a option / alternative to Neo4j. One of the albeit silly, things, that business folks keep referring to is the visualization of nodes and graphs which is something that Neo4j really excels at, even over TigerGraph and Dgraph. RedisInsight has graph visualization support, according to this page:

…and one of the engineers on my team has been able to use / interact with such visualizations/renderings, but I cannot seem to do the same.

I’m running Redis with:

docker run -p 6379:6379 -it --rm redislabs/redisgraph

…and able to connect to it with the CLI via:

docker run -it --network host --rm redis redis-cli -h

…and using RedisInsight via:

docker run --network host -p 8001:8001 -it --rm redislabs/redisinsight

RedisInsight graph does work, however, the visualization of nodes, etc… from queries doesn’t render. The icon that controls the toggle of the view rendered doesn’t even show in my instances of RedisInsight.

The other tabs, JSON and table format work. The redisgraph version is 19901 and Redis is 5.0.5.

I can’t seem to find the source for RedisInsight and have tried entering the container to view the source, but many things are minified making it difficult. I typically use Safari on my Mac, but have tried Google Chrome to see if it renders differently. It does not. Is it possible RedisInsight is checking the version of RedisGraph to determine whether or not it’ll draw/render the graph output?

Thanks for the help and feel free to redirect or yell at me if this is the wrong place. :slight_smile:

Happy new year.


Hi Josh,

Happy new year to you as well. Can you tell me which query you’re running? The graph visualisation is only active when you return actual graph objects.


match (n) return
will not toggle the graph view since it only returns the property name on the node n, but

match (n) return n
will toggle the graph view since it returns the entire node n

If this does not resolve the issue, can you given an example query?


Hey Pieter!

You were spot on, I wasn’t returning a full graph node / object, only subsets of properties for a single or multiple nodes. When I return the full node itself it renders the graph. This is all so, so very slick. Thanks for the support and awesome product.

Cheers, Happy Holidays!

Josh Durbin

+1 (773) 892-4165